martijnnab

Lost Parts Not Calculated In Build Percentage (And Part Overview)

Recommended Posts

Nathan,

 

As I really like the functionality of your site I try to keep my inventory as complete and clean as possible. Recently I added some sets with lots of parts that were missing from the original set, so I used the lost parts section to indicate these.

 

For some reason these parts are not removed from the "My parts" overview (including sets) which is not very handy as I also use the parts overview a lot to see what my inventory of the different parts are (for building my own MOC's for example) I noticed this behavior before, so not sure if this is a bug or programmed behavior.

 

Martijn

Share this post


Link to post
Share on other sites

P.S. I now see I also indicated in the title that the build percentage might be off too. I however don't know that as I have enough parts to compensate so it still off course shows 100%...

Share this post


Link to post
Share on other sites

I just noticed that too. Lost parts are not taken into account when calculating the total number of pieces I own. I hope this is a bug that will eventually be solved. I can't see why it would act like that purposefully.

Share this post


Link to post
Share on other sites

Moreover it seems that if I remove a part from Lost Parts, the amount is added for the part even though it was not originally removed... thus causing the amount of part to be twice what it should be. I am unsure of how to fix the problem myself, since to me it seems now that some set's part count has double the amount of parts to what the set actually has. Is there some way I can see from what set's some given part's set amount consists of? (ie. if I have 20 parts from a set, can I somehow get a breakdown by set for a particular part, that would be nice)

Share this post


Link to post
Share on other sites

To the last question - yep, just go to the part page, scroll down to the Part Usage section, and that'll show you which parts and which colours have been produced in sets. Then click the part and it'll show you which sets, and a count for how many were in that set. Sets you own are highlighted green.

Share this post


Link to post
Share on other sites

Yep! I'm making a full inventory of my parts and this makes it much more complicated. The count in the part overview is next to useless when there are lost parts involved. My older sets were originally reconstructed from the instructions so I normally don't have the extra parts (when I do it's by coincidence). to make thing align with reality, I mark these extra parts as lost but they're not removed from my parts counts. that's quite a peculiar bug since, to me at least, adjusting the parts count is the main reason to have a lost parts feature in the first place.

Share this post


Link to post
Share on other sites

Just noticed a similar issue with lost parts - I have two copies of a set, but one is missing a part. If I mark that piece as lost, the This Set button no longer shows 100%, even though there is one available in the other set!

Share this post


Link to post
Share on other sites