korey99

Import errors from bricklink API?

Recommended Posts

Hello- I created a parts list, and populated it by importing three orders through the bricklink API method.  

Now, this parts list shows 14 parts, but when I drill into the categories, only 6 parts are listed.  The others are wheels with group part numbers (32247c01 for example).

I don't see any errors reported during the import.  Does anyone know what is going on?  

Thanks!

 

2017-01-04 10-30-42_Rebrickable - My Parts.png

Share this post


Link to post
Share on other sites
2 hours ago, korey99 said:

Hello- I created a parts list, and populated it by importing three orders through the bricklink API method.  

Now, this parts list shows 14 parts, but when I drill into the categories, only 6 parts are listed.  The others are wheels with group part numbers (32247c01 for example).

I don't see any errors reported during the import.  Does anyone know what is going on?  

Thanks!

 

2017-01-04 10-30-42_Rebrickable - My Parts.png

Further investigation: if I perform this same task using the XML import rather than the API, I get error messages as expected:  

Part 6538c (5) changed to 59443
Part 4265c (3) changed to 32123b
Part 57029c01 (85) changed to 57796
Part 86652c01 not recognised
Part 86652c01 not recognised
Part 32247c01 not recognised
Part 32247c01 not recognised

So, to clarify: when importing via the BrickLink API, you don't get error messages, and you get these phantom parts in your parts list that cannot be accessed.  

I did another import, of only invalid part numbers, and this part list shows 4 parts, but doesn't actually display any parts.  

 

Share this post


Link to post
Share on other sites