v3 User Sync API Issues via Swagger

Recommended Posts

Question: has anyone been able to use the v3 user POST "sync" API on the Swagger page?

The API in question (third from the bottom):


When I test it with a valid user token, passing valid entries for each field as well as a primary build set number (meaning, someSetNum-1) I get a consistent 404 response code. I have not tried calling into it with actual code, strictly trying to get the Swagger implementation to work first. I do not have any issues with any of the other APIs, no matter the verb.

Any help / insight will be appreciated!

Edited by compassInHand
added more tags and tweaked title slightly

Share this post

Link to post
Share on other sites

When you say not using actual code, are you trying it via the docs page? If so what is the curl command that gets generated? (hide your key and token when pasting)

Share this post

Link to post
Share on other sites

Exactly, from the Swagger docs page. During my testing the other APIs documented via Swagger have worked as expected, and coding against them returns anticipated results. It has only been this one API (again, via Swagger - I have not written any code against it) that returns 404. I did confirm the user and api keys are the same for all Swagger tests.

The curl:

curl -X POST --header 'Content-Type: application/x-www-form-urlencoded' --header 'Accept: application/json' --header 'Authorization: key ApiKeyHere' -d 'quantity=1&include_spares=false&set_num=65081-1' ''

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now