Legolas

Bugs importing from Bricklink order

Recommended Posts

Hi, I was trying to import a bricklink order. I ran into a bug (I think) and trying to work around it I ran into other issues. All using Chrome 58.0.3029.110 (64-bit) on windows.

- On a partlist I clicked the 'Import/Delete Parts' button. In that dialog I clicked 'Bricklink Order'. In the popup I agreed to access, then selected the order from the list., then clicked append. I get a dialog saying: "www.bricklink.com says: Failed to get items"

To work around this, I exported the order to xml on bricklink, and tried to import that. 

- On a partlist I clicked the 'Import/Delete Parts' button. In that dialog selected the exported xml file, which contains 24 items. I select bricklink as the external source, then click append parts. This putput is added to the end of the import dialog:

"

Processing XML file
Converting parts/colors from scheme: BL
Found 22 parts

Warnings:
Part 61678 → 11153 Slope Curved 4 x 1 No Studs [Stud Holder with Symmetric Ridges] (via external system BL map)

"

Note that it reports only 22 items.

Looking at the import, 2 items were not imported: BL numbers 88003-1 (Power Functions L-Motor) and 88004-1 (Power Functions Servo Motor). Looking at their pages on Rebrickable, these BrickLink numbers don't seem to be added there, instead it lists '99498c01' and '99499c01'.

 

Please let me know if you need more information.

Share this post


Link to post
Share on other sites

We currently don't support automatic mappings between sets and parts like this, nothing I can do for now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now