LEGOmuell

Negative Values Shown (Percent & Number of Parts) on Any MOC

Recommended Posts

Bug Description:

When viewing any MOC while logged into my free Rebrickable account, a negative percentage and number of parts are shown (see attached screenshot).

 

How to (possibly) Reproduce this Bug:

Log into a free account on macOS 10.12.6 using Safari 11.0.3 and create two lists grouped by Theme (top level). Mine are named Main Set List and Sets on Display. I have a total of 19 sets with a single duplicate. There are a total of 8 sets that are marked as “Assembled Sets” so they are not calculated in figuring how many parts I already have for a given MOC.

It seems as if the bug appears when I moved those 8 sets to the second set list named “Sets on Display”. When these sets were both marked as “Assembled Sets” and moved to a second set list with the “Use these Sets in Build calculations?” checkbox UNCHECKED, the negative values are shown on any MOC. Once I moved all 8 sets back to the first list (with all default settings except for renaming the set list), the negative value bug is gone.

 

Browser Used:

Safari 11.0.3

 

Operating System Used:

macOS 10.12.6 (Sierra)

Rebrickable Negative Parts for MOC Screenshot 1.jpg

Share this post


Link to post
Share on other sites

The Assembled Sets system doesn't really work in this scenario, as you've discovered. It logically removes parts from your buildable collection, but you don't have those parts in your buildable collection in the first place when the sets with the parts are not in a buildable set list.

I have plans to overhaul this feature to be more flexible and more accurate which should take care of this problem. I don't know when it will happen though.

Share this post


Link to post
Share on other sites