LegoOri

[No Color\any color] bricks appear as missing

Recommended Posts

Hi,

I builk-edited my Decorated Vase MOC to make all the internal bricks colorless.

After the edit my percentage of available parts actually dropped and some of the "no color" bricks are listed as "you don't own these bricks". 

I took a snapshot of the inventory screen, and you can see that the "no color" 1x6 bricks is listed as unavailable (not even "partially available") and the same for the 1x8 bricks and 2x2 cylinders. I have enough bricks un my buildable collection, so that is an error.

Thank you!

LegoOri

Capture.PNG

Share this post


Link to post
Share on other sites

For me it looks perfectly fine. I have enough in my inventory for all the Any Color parts :huh:

Kinda unrelated, but I just had a thought: @Nathan is the system smart enough to give priority to colored parts when calculating building percentage? E.g. if a MOC uses 6 2x4 bricks in red and 6 2x4 bricks in any color and I happen to have 6 2x4 bricks in red it should give priority to the red parts and not the any color parts. Does it do that?

Share this post


Link to post
Share on other sites
9 hours ago, legolijntje said:

For me it looks perfectly fine. I have enough in my inventory for all the Any Color parts :huh:

Kinda unrelated, but I just had a thought: @Nathan is the system smart enough to give priority to colored parts when calculating building percentage? E.g. if a MOC uses 6 2x4 bricks in red and 6 2x4 bricks in any color and I happen to have 6 2x4 bricks in red it should give priority to the red parts and not the any color parts. Does it do that?

No it doesn't. it works it way through the list and whatever is left is reported as missing even if you have that color and was missing an earlier color.

Share this post


Link to post
Share on other sites
On 12/11/2018 at 5:03 PM, LegoOri said:

Hi,

I builk-edited my Decorated Vase MOC to make all the internal bricks colorless.

After the edit my percentage of available parts actually dropped and some of the "no color" bricks are listed as "you don't own these bricks". 

I took a snapshot of the inventory screen, and you can see that the "no color" 1x6 bricks is listed as unavailable (not even "partially available") and the same for the 1x8 bricks and 2x2 cylinders. I have enough bricks un my buildable collection, so that is an error.

Thank you!

LegoOri

Should be working now. The problem only occurred when you have Build settings using Close Colors.

Share this post


Link to post
Share on other sites
On 12/12/2018 at 3:20 AM, biodreamer said:

No it doesn't. it works it way through the list and whatever is left is reported as missing even if you have that color and was missing an earlier color.

That's right. I can't see how to make that smarter without crippling performance.

Share this post


Link to post
Share on other sites
14 hours ago, Nathan said:

That's right. I can't see how to make that smarter without crippling performance.

Isn't that only important when running the large build, when you open the "set" a little more expensive operation can be done to determine the missing parts color for that set only.

and when running the large build the color of the missing parts aren't seen so they aren't important.

Share this post


Link to post
Share on other sites
5 hours ago, biodreamer said:

Isn't that only important when running the large build, when you open the "set" a little more expensive operation can be done to determine the missing parts color for that set only.

and when running the large build the color of the missing parts aren't seen so they aren't important.

Yeah that would be a better way of doing it, but that calculation is so integrated I can't separate it out now without a large redesign.

Share this post


Link to post
Share on other sites