• 0
Vokhev

Picture priority

Question

I'm curious about how the system decides which picture to show in parts lists. I've recently sent in pictures for parts that already had pictures on Rebrickable but that picture didn't respect the standards (either the part showed up twice in the picture, front and back, or the arms were missing from a torso.

My pictures were added (and I later realized there were already photos in some cases) but the same picture still shows in lists so my pictures didn't really help solve the problems I was trying to address.

For the torsos, I noticed that they don't seem to be flagged as "similar picture". Maybe this has something to do with it.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
1 hour ago, Vokhev said:

I'm curious about how the system decides which picture to show in parts lists. I've recently sent in pictures for parts that already had pictures on Rebrickable but that picture didn't respect the standards (either the part showed up twice in the picture, front and back, or the arms were missing from a torso.

 

My pictures were added (and I later realized there were already photos in some cases) but the same picture still shows in lists so my pictures didn't really help solve the problems I was trying to address.

 

For the torsos, I noticed that they don't seem to be flagged as "similar picture". Maybe this has something to do with it.

 

thumb priority is always Element ID, LDraw, then photo. 

Any photos you submitted with just a singular part in it replaced every instance of a photo with multiple angles in one image so once the system updates everything the thumb should sort itself out. 

If there’s no element I’d, ldraw or photo for your color of that part I believe it uses the photo for the color that is most common (in the most sets) so that may impact some. 

Once a photo is added to a part the similar image becomes irrelevant. I try to remember to remove those mappings when I see them but I do miss them as they’re not a priority as they no longer affect the part in any way. So they shouldn’t be affecting any parts that you uploaded photos for. 

Give it a day or so and if nothing changes post some examples and I can have a look for you to check I did things right! 

Share this post


Link to post
Share on other sites
  • 0

Ok, I'll wait a bit and see if it refreshes.

For the parts that showed up twice, I think I know what's happening. It's cases where the Element Id picture has the part on it twice. I guess it keeps its priority even though is doesn't fit the standards. In case where the picture with many parts on them were photos, my new pictures with only one are indeed the default now.

Is there anything we can do about these Element Id pictures with 2 parts or shall we live with them?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Vokhev said:

Is there anything we can do about these Element Id pictures with 2 parts or shall we live with them?

Not as far as I know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now