Nederbrik

[high] IMPORT BL ORDERS - some parts not imported

Recommended Posts

Hi all

If anyone has the time is it possible to look at the printed parts of 85863(total 120 different) they all seem to have the right Bl Nr but not 1 is imported with my Bl orders.

Also by importing my order with over 150 lots i get error 404 that is only the last days so it seems with the latest update there again is a bigger server time out problem.

That also means that not the complete order is imported and if it is not recognized you loose parts.

Thanks

Share this post


Link to post
Share on other sites

Hi, Nederbrik,

can you find out which one is causing the problem? I did a quick check of the part mappings of 85863, but they all seem to be defined, and all seem to link to existing BL part numbers, cause none of them appears in my private Missing BL Maps list.

Take care,

Simon

Share this post


Link to post
Share on other sites

All of them go wrong, this week also other new parts reported by change request more and more are failing to be imported no idea why some did work a few weeks ago and now they don't.

But all the printed of 85863 120 in total are ignored so there has to be something wrong.

Toby has already don a few other parts this week and just submitted a few last night, Bl Nr is right but they won't be imported and are just ignored by the system.

Share this post


Link to post
Share on other sites

I've tested a random 10 printed versions, and the BL mapping seems to be okay. Do you have a xml or csv file that you use for the import, that I can use for testing?

Share this post


Link to post
Share on other sites

Sorry all but this has to be in Dutch to explain myself

Wat ik doe is niet maar dan een import van Bl naar mijn standaard lege part list 00, als het goed is kun je meekijken, hij is nu leeg.

Dan via de knop Import/ Delete parts, dan Bl Order en dan selekteer ik de order die ik nodig heb.

Dus nu mijn vraag hoe kom ik aan een xml of csv bestand van Bl.

Bij de import van Bl moet ik met een lege lijst werken omdat er tussen de 5 en 10% van de onderdelen niet worden geimorteerd dus moet ik alles 2x checken voor ik uit kan sorteren over de andere 49 lijsten.

Part 11301 werkt nu.

Share this post


Link to post
Share on other sites
14 hours ago, Nederbrik said:

All of them go wrong, this week also other new parts reported by change request more and more are failing to be imported no idea why some did work a few weeks ago and now they don't.

But all the printed of 85863 120 in total are ignored so there has to be something wrong.

Toby has already don a few other parts this week and just submitted a few last night, Bl Nr is right but they won't be imported and are just ignored by the system.

I've made a change that might fix this for you, could you please try again?

Share this post


Link to post
Share on other sites
2 hours ago, Nathan said:

I've made a change that might fix this for you, could you please try again?

Sorry not yet, in my last order there were also 8 in it and all 8 are not imported ore ignored.

I have now 107 of them only 13 to go, but not 1 was imported on the right way.

Share this post


Link to post
Share on other sites
3 hours ago, Nederbrik said:

Sorry not yet, in my last order there were also 8 in it and all 8 are not imported ore ignored.

I have now 107 of them only 13 to go, but not 1 was imported on the right way.

If you export your order to XML and import that as a file, how does it go? If it still fails, can you please email me the file to [email protected]

Share this post


Link to post
Share on other sites
2 hours ago, TobyMac said:

Which 13 are those?

Here they are it seems to be 15 of the 120 stil not in my collection.

85863pb028/044/078/083/095/097/098

85863pb101/102/103/104/105/106/107/108

Share this post


Link to post
Share on other sites
1 hour ago, Nathan said:

If you export your order to XML and import that as a file, how does it go? If it still fails, can you please email me the file to [email protected]

No idea how i can download my Bl order as a xml, did ask that yesterday in Dutch but no replay ore explanation.

I can't find that option on my Bl order page.

Share this post


Link to post
Share on other sites

Sorry i do not get this info that it is moved to bugs can you take a look for that, did already give up because i could not find my post anymore.

Found the xml way on bricklink has to search in Bl classic and will send the xml later.

Also tried an upload to my custom lists they are ignored and not mentioned that they are ignored.

Share this post


Link to post
Share on other sites

@Nederbrik

if you can't find a post you made, click on your own name (top right), select Profile and then click See my activity. All your posts are there.

If you are unsure about your English; write your post in Dutch (using Wordpad or something); use Google Translate to create a translated version, and post them both.

The following is done with Google Translate.

===

Als u een bericht dat u hebt geplaatst niet kunt vinden, klikt u op uw eigen naam (rechtsboven), selecteert u Profiel en klikt u vervolgens op Mijn activiteit bekijken. Al je berichten zijn er.

Als je onzeker bent over je Engels; schrijf je bericht in het Nederlands (met Wordpad of zoiets); gebruik Google Translate om een vertaalde versie te maken en beide te posten.

Het volgende gebeurt met Google Translate.

===

Take care
Simon

Share this post


Link to post
Share on other sites

In the XML file you sent me, there are only 31 parts and all of them imported when I tested it. How many are you expecting for that file? There are also 9 minifigs in the order which is not something we can import.

Share this post


Link to post
Share on other sites
On 3/4/2019 at 7:21 AM, Nathan said:

In the XML file you sent me, there are only 31 parts and all of them imported when I tested it. How many are you expecting for that file? There are also 9 minifigs in the order which is not something we can import.

That is the problem the minifigs are not minifigs but just 1 piece printed parts so importing most go right, they have nothing to do with the other 4 piece minifigs.

The unprinted versions are imported right so something in the database structure is preventing it from working right.

I stil get no emails from the forum, so i can not respond on anything also did get no privat mail that is or something like that.

Share this post


Link to post
Share on other sites

@JJS That BL mapping is incorrect. BL mappings with ‘bb’ prefix tend to be temp numbers. If you ever see one on a newer part and it doesn’t work question it.

i will find and update the mapping. Give me 10 mins. 

Edit: done. It should work now. 

Share this post


Link to post
Share on other sites

Further addition to the wrongly import, all micofigs have to show up on this page but there are only 5 showing of the 110.

So the problem seems to be that all microifigs are turned of, by my simple thought they have to be turned on just like the Technic figures and the older Junior/4Juniors figures then the import will go right.

Share this post


Link to post
Share on other sites
10 hours ago, Nederbrik said:

Further addition to the wrongly import, all micofigs have to show up on this page but there are only 5 showing of the 110.

So the problem seems to be that all microifigs are turned of, by my simple thought they have to be turned on just like the Technic figures and the older Junior/4Juniors figures then the import will go right.

That’s because you have the show printed parts box unchecked. So the results are ignoring parts with print relations. Tick the box and they all should appear

Share this post


Link to post
Share on other sites

But i do not understand why they can not be imported from an Bl order it are just printed parts every other printed part containing just 1 part can be imported what is different by these parts.

Share this post


Link to post
Share on other sites
23 minutes ago, Nederbrik said:

But i do not understand why they can not be imported from an Bl order it are just printed parts every other printed part containing just 1 part can be imported what is different by these parts.

There's no reason the import for these parts (the microfigs) shouldn't be working. They are active and the handful I checked have the correct mappings.

Share this post


Link to post
Share on other sites

This week i will get an order with some more well see if it works till now not 1 could be imported with my orders.

Share this post


Link to post
Share on other sites

Just made a test run and it is still not working BL numbers are

85863pb083 > Rebrick 85863pr0090

85863pb078 > Rebrick 85863pr0085

This are just printed parts and made out of 1 part so i still can not believe that the reason they are not imported is because they are minifigs.

So can you take a look again.

Share this post


Link to post
Share on other sites
12 hours ago, Nederbrik said:

Just made a test run and it is still not working BL numbers are

85863pb083 > Rebrick 85863pr0090

85863pb078 > Rebrick 85863pr0085

This are just printed parts and made out of 1 part so i still can not believe that the reason they are not imported is because they are minifigs.

So can you take a look again.

I've looked at these and have submitted a possible reason to Nathan to check.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now