• 0
Retrieverfalcon

Order of Sub-Sets on Alt Builds Tab

Question

Currently, the order in the sub-set section of the Alt Builds Tab is the order they were submitted or approved (not exactly sure which governs). As a user, I think this would be better presented either in set number order or alphabetically (or ideally, a toggle to do either). An example is below from the Alt Builds tab of 75184-1. You'll see that it is ordered as -4, -2, -3, -5, etc. The submitters likely numbered the subsets in some logical fashion - days in an advent calendar, order of presentation in the instructions of a Classic Set, etc. However, these sets aren't always added to the system in that order for any number of reasons (some are easier to do, one is more interesting today than another, whatever). Ideally, the system would be smart enough to just correct this.

I would suggest they be ordered by set number or at least in alpha order by set name.  Currently, it's just a hodgepodge.

One edge case to mention - for now, LEGO Idea ReBuilds are categorized as "sub-sets" and named with the -c suffix. While ideally these would get their own area on the Alt Builds tab, they should not be sorted intermixed with the normal subsets if sorting by set number. If conventions are followed, this would make all of these appear first since -c would proceed -s sets. That's not ideal but better than them being mixed in.

800x733.jpg

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I've added ordering by set number. It's not a numeric field though, so the ordering will be -1, -11 instead of -1, -2. But at least it's consistent now.

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Nathan said:

I've added ordering by set number. It's not a numeric field though, so the ordering will be -1, -11 instead of -1, -2. But at least it's consistent now.

I have no qualms with that. If it is a major issue on a given set, it is easily overcame with renumbering sets -1 to -9 as -01 to -09. 

That said, though, when I just checked, this change does not appear to be taking effect. Do I need to do something to enable it?

Share this post


Link to post
Share on other sites
  • 0

Oops, I haven't deployed it yet :) I need to wait for some image processing stuff to finish which might take a few hours.

I have actually modified the change to work numerically where possible for this specific tab. However, getting that to work on all set listings is a much harder problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now